Shopify API response times have returned to normal, and checkout performance has fully recovered.
All order placements and checkout flows are now functioning as expected.
Posted Jan 04, 2026 - 15:38 IST
Identified
We have identified the cause of the ongoing checkout slowness.
Certain external Shopify APIs are experiencing elevated response times, which is impacting real-time checkout steps such as order creation and validation.
Impact - 1. Checkout pages may load slower than usual 2. Order placement may take longer to complete 3. Other Shopflo functionalities continue to work as expected 4. Only a subset of stores is impacted
What We’re Doing - 1. Actively coordinating and monitoring Shopify API performance 2. Applying safeguards and retries to reduce checkout failures 3. Continuously tracking latency to prevent further degradation
Posted Jan 04, 2026 - 15:10 IST
Investigating
We are currently observing increased checkout load times and slower order placements for some stores.
Our initial investigation indicates that external Shopify APIs are responding slower than normal, which is impacting certain real-time checkout operations that depend on Shopify systems.
Posted Jan 04, 2026 - 14:58 IST
This incident affected: Checkout Service and Shopify API & Mobile.