Shopflo Checkout V2 Token Flow - Address Submit Page Issue

Incident Report for Shopflo

Postmortem

Status: Resolved
Impact: High
Duration: 7 hours (3:00 AM - 10:00 AM)
Affected Service: Shopflo Checkout (V2 Token API Flow for Custom Integration)

Summary

Merchants who are using the V2 Token API flow in Shopflo Checkout, their customers were unable to proceed beyond the address submission page due to a disabled submit button, preventing order completion for legacy integrations.

Impact

  • Address submit button remained disabled after customers entered shipping/billing addresses
  • Customers unable to progress to payment or order review steps
  • Potential revenue loss from abandoned carts during 7-hour window
  • Affected brands using legacy V2 Token API flow

Root Cause

A new required parameter shop_url was introduced during the 3:00 AM deployment. The frontend validation logic required this parameter to enable the address submit button. Legacy brand integrations were missing this parameter, causing the submit button to remain disabled even when all address fields were completed.

Resolution

  • Identified missing shop_url parameter in legacy V2 Token flow integrations
  • Updated frontend validation logic to handle legacy integrations without the parameter
  • Applied backward compatibility fix to enable button submission for both legacy and new integration formats

Timeline

  • 3:00 AM - Deployment introduced shop_url parameter requirement in frontend validation
  • 09:30 AM - Issue reported by affected customers unable to submit addresses
  • 09:45 AM - Root cause identified as disabled submit button due to missing parameter
  • 10:00 AM - Frontend validation fix deployed
  • 10:05 AM - Submit button functionality restored for all brands

Next Steps

  • Audit all V2 Token flow integrations to identify legacy implementations
  • Implement gradual migration plan for legacy brands to include shop_url parameter
  • Enhance frontend validation testing to include legacy integration scenarios
  • Add monitoring for disabled checkout buttons across different integration types
Posted Sep 12, 2025 - 15:05 IST

Resolved

Merchants who are using the V2 Token flow in Shopflo Checkout, their customers were unable to proceed beyond the address submission page due to a disabled submit button, preventing order completion for legacy integrations.
Posted Sep 11, 2025 - 10:00 IST