The issue impacting prepaid order placements for a small subset of customers has been fully resolved.
All systems are operating normally. We continue to monitor performance, but no further impact is expected.
Posted Nov 28, 2025 - 20:52 IST
Monitoring
A database failover has been successfully performed to mitigate the replication-induced latency. Error rates for prepaid order placement have now returned to normal levels.
We are currently monitoring system performance and validating end-to-end prepaid checkout flows to ensure full stability.
Posted Nov 28, 2025 - 19:49 IST
Identified
We have identified the root cause of elevated prepaid order placement errors. The issue was triggered by database replication activity, which temporarily increased latency on the prepaid order creation path.
Posted Nov 28, 2025 - 19:47 IST
Investigating
We are currently seeing elevated errors in prepaid order placement, impacting a subset of customers attempting to complete prepaid checkouts. Our team is investigating the root cause and working on a mitigation.