Download Report Functionality Not Working

Incident Report for Shopflo

Resolved

The issue is fixed and all the previous data is verified and back populated.
Posted Sep 11, 2025 - 19:14 IST

Update

Team is working on revalidating all the data.
Posted Sep 11, 2025 - 18:12 IST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 11, 2025 - 12:29 IST

Investigating

We are currently experiencing an issue where users are unable to download reports. Our engineering team is actively investigating the root cause.

Impact:
• Report downloads are failing for all users.
• Other platform functionality remains unaffected.
Posted Sep 11, 2025 - 10:39 IST
This incident affected: Analytics service.