Checkout slowness caused by elevated Shopify API response times has been fully resolved.
Shopify API performance has remained stable after monitoring, and all checkout flows and order placements are now operating normally.
Posted Jan 07, 2026 - 16:10 IST
Monitoring
The issue causing checkout slowness has been fixed, and Shopify API response times are back to normal.
Checkout flows and order placements are functioning as expected. We are actively monitoring the system to ensure stability before marking the incident as fully resolved.
Posted Jan 07, 2026 - 15:50 IST
Investigating
We are again observing checkout slowness and delayed order placements for some stores.
Early indicators suggest elevated response times from Shopify APIs used during order placement and checkout validation.
Impact 1. Checkout pages may load slower than usual 2. Order placement may take longer to complete 3. Other Shopflo features continue to work as expected 4. Impact is limited to a subset of stores
Current Actions 1. Engineering team is actively investigating 2. Shopify API performance is being closely monitored 3. Retry and fallback mechanisms are in place to minimize failures
Posted Jan 07, 2026 - 15:40 IST
This incident affected: Checkout Service and Shopify API & Mobile.