Dashboards & Reports Not Loading

Incident Report for Shopflo

Resolved

The issue affecting dashboard and report loading has been fully resolved.

All data — including both today’s and historical data — is now loading correctly.

We will continue to monitor system performance to ensure stability.

Thank you for your patience while we worked to restore service.
Posted Nov 11, 2025 - 15:49 IST

Identified

We have identified the issue. Loading of today’s data has been fixed and dashboards/reports for today should now be working as expected.

However, loading of historical/past data is still impacted and may continue to fail intermittently. The engineering team is actively working on fixing the remaining issues.

We will provide another update once past data is fully recovered.

Once restored no data will be missed from the reports/dashboard.
Posted Nov 11, 2025 - 11:03 IST

Investigating

We are seeing elevated failures when attempting to load dashboards and report views. The engineering team is actively investigating the root cause.

Users are currently unable to load dashboards and reports. This includes delays or timeouts while accessing analytics pages.

We will share an update as soon as we have more information.
Posted Nov 11, 2025 - 11:01 IST
This incident affected: Analytics service.